Desired Features/Packages

What packages would you like to see available on the host? man? gcc? wget?

List them in this topic/thread, and your wish may well be granted!

He who asks is a fool for a moment, whilst he who does not is a fool forever. If we don't know what things you would like, then we have no way of fulfilling your wishes!

tomjerr's picture

hallo
if this possible for me to asking this packages then i'm glad if the admin accepting my request to install gcc n wget packages,thx before :)

Is there a chance to install screen ? Thanks

Onlyodin's picture

Yes. I'm surprised I hadn't installed it thus far.

Thanks.

Is it possible to get some text mode web browsers like lynx or elinks? Thanks...

Will we be able to receive mail at *@{us.}yunix.net at some point?

Onlyodin's picture

Is there a need to be able to receive mail?

I would have thought it was a redundant service, you obviously have an existing email account (in order to register), why would you need more?

I travel a lot, often in places where access is shaky or insecure; tunneling into my shell account and keeping/picking up mail there would be very convenient. Also, no need to access web GUIs, etc. But I'd understand if you'd rather not put more load on the server at this time. I asked because I noticed SMTP from us.yunix.net works.

Could you please install nano or pico? They are text editors, I believe nano is just a GNU port of pico, but either will do... I just can't stand vi personally.

Thanks

Onlyodin's picture

nano is now installed.

Best shell ! ;)

Onlyodin's picture

That's great! Feel free to send a donation!

Could you pls install the ncurses library? TY

Onlyodin's picture

ncurses and ncurses-libs were both installed, but assuming whatever it is you're trying to do isn't working, I've installed ncurses-devel as well.

I'm tryin to use make config in psybnc.

a possible feature request, please..
I've been trying to get vi/vim syntax highlighting to work..
I don't really know what I'm doing.. but..
been playing around with ~/.virc and all that .. but no go.

Apparently - this *might* have something to do with it:
>>Looks like your are running CentOS. Make sure that you installed vim-enhanced package:
>>rpm -qa | grep vim
>>vim-minimal-7.0.109-4.el5_2.4z
>>vim-enhanced-7.0.109-7.el5
>>vim-common-7.0.109-7.el5
(ref http://serverfault.com/questions/305112/how-to-enable-color-in-vim-over-ssh)
on here:
it seems we only have vim-minimal*
Any chance for the other two modules.. or packages rather ? - if that's where the problem
is? - and I'm not even sure because I seem to be able to ssh into my own fedora-box
which only has the vim_minimal* and still get syntax highlighting.
thanks.

Onlyodin's picture

I've installed vim-enhanced, you may need to log out and back in for the alias to take effect.

Thanks.. syntax highlighting works now :-)

reario's picture

Hi, I'm an old emacs user and I'd like to have emacs installed.....
Thanks, Vittorio

Onlyodin's picture

Ok.

Emacs has been installed.

reario's picture

Hi, I've also noticed that GIT client is missing....I need to download my sources from git.hub and to be in sync with my repository. It is possible to install git? thanks again, vittorio

Onlyodin's picture

Yep, git is now installed.

hello,
Any chance for an installation of the Python Imaging Library (or PIL)?
there are RPMs for it.
Thanks.

Onlyodin's picture

python-imaging has been installed. Does this give you the functionality you're after?

Thanks,
I'm in the middle of something this week so I can't check for sure, but I'm pretty sure that I'll now
have the functionailty I need.

Please install fortune and bsdgames! Essential for a proper shell :)

Onlyodin's picture

fortune is installed, but there's no bsdgames package for RHEL/SL6.

For no good reason I've mangled /etc/profile with a cowsay fortune.

Thanks! A shame on the bsdgames package, though.

Onlyodin's picture

You're welcome to go looking for equivalents that have been packaged for RHEL6/SL6/C*ntOS6.

Could you please install java?It is very useful.
Thanks.

Kobryn's picture

If it's at all possible, Scrollz is a substantially more flexible IRC client than Irssi.

Onlyodin's picture

Is there a package in epel/rpmforge/etc for this?

Otherwise, you can always compile it for yourself.

Hi to all,
I don't know if the service already provides a personal HTTP static repository (without any interpreter for PHP, Python or CGI for other scripting/programming languages), that can be reached by a URL http://yunix.net/~username. I would know if is possibile to get this feature or not. I'd like to put some data and retrieve them by HTTP protocol from an HTML page.

Thank you all and compliments for that service,
Joe.

I use telnet for playing a virtual game on telehack.com(its a 1980s-1990s arpanet simulation with virtual hosts and files from that era). So if telnet can be installed it would be a great help so I can have just one window open and use screen(I use windows at work so I don't have screen there :( )

I found this link for bsdgames: http://www.melvilletheatre.com/articles/el5/index.html. I don't know much about centos but I think this should work.

Thanks.

Onlyodin's picture

Unfortunately those packages are for CentOS 5 (RHEL5), whereas yunix is running Scientific Linux 6 (RHEL6).

If you can find equivalent packages for el6 (CentOS 6, RHEL6, etc) then I would be happy to look at loading them.

http://rpm.pbone.net/index.php3/stat/4/idpl/2394771/dir/redhat_6.x/com/b.... I think this should do it. :)

Any updates on telnet ? If it is insecure or something I understand.

Onlyodin's picture

You realise that rpm was for Red Hat 6, back in 1999? (This pre-dates CentOS, Fedora, Ubuntu, and many more distributions)

I'll have a look and see, but no guarantees.

And in regards to telnet, no, sorry. ssh has equivalent functionality without the same inherent security risks. There's just too many users and too great a risk imho.

Hi,
Would it be possible for mod_wsgi to be installed for Apache?
(enables hosted python applications / possibly Django)
Thanks and Regards.

Hi. Is it possible to install the perl module Crypt::CBC. Thanks a lot for all.

Onlyodin's picture

Apologies for the delay, the Crypt::CBC module has been installed.

Thanks :) By the way, today i have some problems connecting, its only me ?